Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mounting a Haiku/bfs partition

 
Post new topic   Reply to topic    Syllable Forum Index -> Bugs
View previous topic :: View next topic  
Author Message
Ronaldlees



Joined: 15 Oct 2014
Posts: 146

PostPosted: Sat Nov 01, 2014 8:26 am    Post subject: Mounting a Haiku/bfs partition Reply with quote

How time flies when you're having fun. I looked at my first post here, and see it's been a couple weeks already. Have been putting Syllable through it's paces, and have been making most of my forum postings with Syylable/Webster (including other forums rather than this one). Webster does the forum thing quite well. It does get bogged down on the big sites (news sites, mainly).

Anyway - I have both Syllable and Haiku on the hard drive on this machine. I use Haiku's boot loader, and then have the GRUB for Syllable set up in a partition. Works fabulously. But, when I try to mount the Haiku partition from Syllable, by right clicking in the graphical disk utility, the file browser shows me only the "apps" directory on the Haiku partition. It's like something's not quite meshed together correctly..

Perhaps Syllable is mistaking the Haiku partition for an AFS? I suppose I should try to explicitly mount the partition from the command line, rather than automounting with the disk utility...
Back to top
View user's profile Send private message
Ronaldlees



Joined: 15 Oct 2014
Posts: 146

PostPosted: Sat Nov 01, 2014 10:29 am    Post subject: Reply with quote

Well, it works fine from the command line. Can see/read all of the directories/files.

Guess the file browser is at fault, and not the mount process. It doesn't really make sense that the mount GUI could have mistaken anything, as the filesystem is identified with a specific ID, right? So no mistake there, and apparently just a file browser bug.
Back to top
View user's profile Send private message
Ronaldlees



Joined: 15 Oct 2014
Posts: 146

PostPosted: Sat Nov 01, 2014 10:36 am    Post subject: Reply with quote

In a terminal, I can browse the files in all of the haiku directories. But, even when haiku is mounted via the command line, the file browser GUI shows only the "apps" directory.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2202
Location: Friesland

PostPosted: Sat Nov 01, 2014 4:13 pm    Post subject: Reply with quote

Interesting, thanks for the report.

I do know that the filer often hangs after renaming a file in it. Initially, it just seems to be the screen update that should happpen hanging, but to prevent it from hanging more severely, I close it immediately and open a new filer.

You seem to have found a new source of this, or something similar, happening.

I think this is a regression: it didn't happen in previous Syllable versions. It seems to have something to do with node monitoring and how the filer processes those events.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group