Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

mount USB stick

 
Post new topic   Reply to topic    Syllable Forum Index -> Syllable Desktop
View previous topic :: View next topic  
Author Message
brodsky



Joined: 08 Jan 2015
Posts: 6

PostPosted: Thu Jan 08, 2015 8:47 am    Post subject: mount USB stick Reply with quote

Could you please explain me how to mount USB stick?

There is /dev/usb present, I assumed it should be something like:

mount /dev/usb /mnt/usb

It does not work with message "device not found"

Next I ran Device Manager and noticed the following device:
/dev/disk/scsi/raw

(not sure it is exact, I don't have the systen up before me now). I found in some mailing list answer a notice that USB should be mounted with type scsi. So I tried the following:

mount /dev/disk/scsi/raw /mnt/usb -t scsi

It did not work either.

I tried different options and combinations, for example:

mount /dev/usb/0 /mnt/usb -t scsi

Nothing works.

Could you please suggest what should I do?

The system an old laptop with Pentium-3 and one USB.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2201
Location: Friesland

PostPosted: Thu Jan 08, 2015 8:54 pm    Post subject: Reply with quote

Please read the relevant section of the Welcome document. It's on your desktop and here:

http://web.syllable.org/Desktop/Welcome.html#storage

/dev/usb is a low level USB device driver, but you want to mount a file system, so you need the SCSI emulation drivers under /dev/disk/scsi/

If you want to do it from the command line, you should pass the type of the file system, not of the device interface. It works the same on other operating systems. For a USB stick, that's usually FAT, but it's much more comfortable to just let the system detect the type automatically.
Back to top
View user's profile Send private message Visit poster's website
brodsky



Joined: 08 Jan 2015
Posts: 6

PostPosted: Fri Jan 09, 2015 6:41 am    Post subject: Reply with quote

Thanks very much!

I tried the GUI but while I see directories I cannot access any file. The directories content (list of file names) is replaced by a list of numbers, mainly 0 or 00.

The USB stick file system is FAT32. The parameter for -t should be vfat, correct? It does not work.

By the way I tried -t iso9660 and got the same wrong result as with GUI. My assumption is that GUI wrongly recognizes the system as iso9660 and FAT32 is not supported correctly. I saw a defect in the bug list about the issue.

Are there extra drivers to load? Another options to specify? Parameters to set?
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2201
Location: Friesland

PostPosted: Sat Jan 10, 2015 1:01 pm    Post subject: Reply with quote

I'm not sure about the type name, but vfat is probably correct. But again, not specifying it means that the file system drivers detect the type automatically, so you almost can't go wrong that way.

There is also little reason not to use the Disks GUI for mounting. The GUI does not detect the type, the kernel drivers always do that. It's just a user interface. However, the filer can hang on mounting or changing the file system, so if that happens, the command line could be a fallback to try to make it work.

I haven't heard of your particular directory corruption before. It's possible that you are causing it by forcing the file system to a type that it is not. Is there a partition on the USB stick? If there is a partition, you have to mount that instead of the raw disk.
Back to top
View user's profile Send private message Visit poster's website
brodsky



Joined: 08 Jan 2015
Posts: 6

PostPosted: Sat Jan 10, 2015 1:53 pm    Post subject: Reply with quote

Yes there is a partition and I do specify it.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2201
Location: Friesland

PostPosted: Sat Jan 10, 2015 7:14 pm    Post subject: Reply with quote

Does it mount when you don't specify the type?

If you still get the same corruption, it must be a bug in the FAT driver. There are some known ones, but not particularly this one.

It could also be the USB driver, but I wouldn't expect it to mount then.
Back to top
View user's profile Send private message Visit poster's website
brodsky



Joined: 08 Jan 2015
Posts: 6

PostPosted: Sun Jan 11, 2015 1:45 am    Post subject: Reply with quote

Yes, the same behavior when I mount from command line without specifying the type.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2201
Location: Friesland

PostPosted: Mon Jan 12, 2015 1:43 pm    Post subject: Reply with quote

It's fairly sure to be a problem in the FAT driver, then.

How large is your partition?
Back to top
View user's profile Send private message Visit poster's website
brodsky



Joined: 08 Jan 2015
Posts: 6

PostPosted: Mon Jan 12, 2015 4:22 pm    Post subject: Reply with quote

32 GB
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2201
Location: Friesland

PostPosted: Tue Jan 13, 2015 12:26 am    Post subject: Reply with quote

It's possible that the size is a problem. Can you mount smaller sticks, or a smaller partition on the same stick?
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Syllable Desktop All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group