Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bug 208 Appserver crashes with using a FireGL v3400

 
Post new topic   Reply to topic    Syllable Forum Index -> Bugs - Fixed
View previous topic :: View next topic  
Author Message
nos



Joined: 17 Sep 2007
Posts: 95

PostPosted: Sat Nov 17, 2007 5:12 am    Post subject: Bug 208 Appserver crashes with using a FireGL v3400 Reply with quote

Bug Id ?
208 / [Show Bug History]
Reporter ?
adamk
Product/Version ?
Syllable / 0.6.4
Status ?
Unconfirmed
Severity ?
Moderate
Duplicate Of ?
- none -
Summary ?
Appserver crashes with using a FireGL v3400
Report Time ?
March 26, 2007 07:45:30 PM
Assignment ?
- none -
Resolution ?
Open
Priority ?
Normal
Dependencies ?
- none -


Votes
For: 0 (0%)
Against: 0 (0%)
Total: 0

March 26, 2007 07:45:30 PM adamk

Thinking that by previous bug might have to do with the radeon driver, I decided to switch out the x800 for a firegl v3400, which would be unsupported and fallback to the vesa driver. It does, indeed, fall back, but it also causes the appserver to crash:

http://68.45.180.45/syllable-03.22.07-firegl.v3400.txt.gz

Adam

March 26, 2007 07:46:31 PM adamk

Oh, and this does happen if I disable_smp or disable_acpi (though I didn't try both at the same time).

Adam

March 26, 2007 10:02:11 PM adamk

Alright, so this is a little scary. I replace the v3400 with the x800 again (to test disable_smp and disable_acpi per Vander's suggestion in 206).. After I tested those options, I swapped back to the v3400. Unfortunately, a minute or two after booting up, the screen blanked and the fan on the card kicked into high gear. I booted into Windows, only to have the same thing happen. I then tried linux. Same thing. I was still able to login via ssh, and ran an 'lspci'. The card was no longer recognized by the system. I rebooted back into linux. Before the screens had a chance to blank, and the fan to kick in, I logged in and did an lspci. The system recognized the card as a FireGL v3400 video controller. A minute later, the screens blanked (went into sleep mode), the fan on the card went up a notch, and lspci showed 'unknown card'.

Anyway, nothing I've done has gotten the v3400 working again. Now... Is there any chance that syllable could have done something to my card? Smile Seriously, it's not a huge deal since I almost never use this card, and I know the risks involved in testing an operating system, but I'd be curious to know what you guys think.

Adam

March 27, 2007 05:30:43 AM Mar
A display driver can at least theoretically overclock a graphics card's RAM or GPU enough to cause damage.

Try clearing the system's CMOS and see if the card will work again after that.

March 27, 2007 05:56:18 AM Vanders
A VESA driver crash! That is a new one Smile

As Mar says, it is theoretically possible for a driver to damage the hardware, but as Syllable never detected your card the Radeon driver was not in use, and the VESA BIOS was only used to change screen mode. Unless the BIOS was buggy, I doubt the card was ever overclocked.

I suspect that it is more likely the card is/was marginal, and this is what has caused both the crash and the card to no longer work.

March 27, 2007 07:13:58 AM Mar
To be safe, you should install the appropriate system monitoring software for your motherboard to make sure the power supply unit is supplying voltages correctly and consistantly.

March 27, 2007 09:10:36 AM adamk

Yeah, I already have such a utility. Everything appears normal. While I try to be careful, I have switched video cards on this machine quite a bit lately, including the v3400. I probably accidentally damaged the card.

In any case, I'm switching back to the X800 for an extended time. I do have an X1300 which, like the firegl v3400, falls back to the vesa driver, and causes the appserver to crash.

March 27, 2007 08:43:18 PM adamk

Well, the v3400 appears to be beyond saving. I upgraded the BIOS on my workstation and reset the CMOS too. Still encounter the same problem with the v3400. It's fine for a few minutes, till it just seemingly shuts off. I'm rather certain, however, that this has more to do with how I handle my cards than with Syllable Smile If I get a chance, and can figure out how, I'll look into flashing the BIOS of the card to see if it makes a difference.

And, finally, I confirmed that even after the BIOS upgrade on my workstation, the vesa driver still crashes the appserver with the x1300. I'm going to switch back to the x800, and will undoubtedly stick that.

Adam

March 28, 2007 06:56:07 AM Mar
The heatsink on the GPU may be partially dislodged if it's fine for a few minutes then shuts off.

March 28, 2007 09:15:23 AM adamk

Thanks for your help with this (especially since it seems to be completely unrelated to Syllable). I'll take a look at the card when I get home today.

March 28, 2007 08:42:25 PM adamk

FYI, it doesn't appear to be the heatsink and/or fan.

April 14, 2007 12:19:15 PM adamk

FYI, the vesa crash appears to be fixed in the April 8th build. I guess this can be closed now.

April 14, 2007 12:56:29 PM Kaj
Hm, I'm not sure we changed anything to make this so.

April 14, 2007 01:51:07 PM adamk

Well, it definitely crashed on the previous build.. I installed it on this machine three times and testing with the v3400 in the first install, and the x1300 on both the first and second installs. I don't think I tried the third time, already convinced it was broken.

And now, it works Smile Hmmm.... I did update the BIOS on my machine to see if it would resolve #206 (which it didn't), but I don't remember at what point I tried that. It could be after the 2nd install of the previous build, so perhaps that's what solved this problem.

Powered by Bugdar 1.1.4
Copyright ę2002 - 2007, Blue Static
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Bugs - Fixed All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group