Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Applications

 
Post new topic   Reply to topic    Syllable Forum Index -> Bugs - Fixed
View previous topic :: View next topic  
Author Message
Ondras



Joined: 06 Feb 2009
Posts: 20
Location: Czech Republic, Prague

PostPosted: Sun Mar 15, 2009 12:04 pm    Post subject: Applications Reply with quote

I testing any application ( dosbox,wesnoth etc) and however no run in syllable 0.6.6, but in syllable 0.6.5 normal run.Where is can error...
?

If development team wants I will test all software for syllable during week...
Wink
Back to top
View user's profile Send private message Send e-mail
Morph
The Knights of Syllable


Joined: 18 Oct 2007
Posts: 316
Location: Australia

PostPosted: Sun Mar 15, 2009 12:22 pm    Post subject: Reply with quote

After you try to run an application, could you check the system log and post any relevant lines here? The log is at /boot/var/log/kernel and the relevant lines will be the ones that mention the application right at the end of the file.
Thanks!
Back to top
View user's profile Send private message Visit poster's website
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2204
Location: Friesland

PostPosted: Mon Mar 16, 2009 9:09 am    Post subject: Reply with quote

Is that on the 0.6.6 Release Candidate? That has a new SDL version that needs to be tested, so this may point to an important problem.
Back to top
View user's profile Send private message Visit poster's website
NecroRomancist



Joined: 18 Sep 2007
Posts: 272

PostPosted: Tue Mar 17, 2009 7:27 pm    Post subject: Reply with quote

I tried zsnes and it worked..so maybe it maybe something else..
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2204
Location: Friesland

PostPosted: Tue Mar 17, 2009 7:54 pm    Post subject: Reply with quote

Hm, we really need more detailed logs here. Any chance you could try DOSBox and Wesnoth?
Back to top
View user's profile Send private message Visit poster's website
NecroRomancist



Joined: 18 Sep 2007
Posts: 272

PostPosted: Wed Mar 18, 2009 12:35 pm    Post subject: Reply with quote

I'll test them tonight.. The only thing i can remember is that somehow during the build there is a problem with the other sdl libs (sdl image,sdl net...).
Dosbox uses sdl net, wesnoth uses almost all of them.. whereas zsnes uses only SDL.
Back to top
View user's profile Send private message
Ondras



Joined: 06 Feb 2009
Posts: 20
Location: Czech Republic, Prague

PostPosted: Wed Mar 18, 2009 4:48 pm    Post subject: Reply with quote

[img]http://syllable-os.wz.cz/kernel.JPG[/img]

It is see here...
Back to top
View user's profile Send private message Send e-mail
Ondras



Joined: 06 Feb 2009
Posts: 20
Location: Czech Republic, Prague

PostPosted: Wed Mar 18, 2009 5:06 pm    Post subject: Reply with quote

I am sorry, but I writed during week any time for syllable...

A need study set theory,analytical philosophy etc. and see serial Bleach Very Happy Very Happy ... and I am extra lazy few yers Very Happy ... this is any for titter Wink

Tomorow I write list with applications , which no run...ok For enterety
Back to top
View user's profile Send private message Send e-mail
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2204
Location: Friesland

PostPosted: Wed Mar 18, 2009 6:17 pm    Post subject: Reply with quote

Thanks, that's exactly the info we needed.
Back to top
View user's profile Send private message Visit poster's website
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2204
Location: Friesland

PostPosted: Thu Mar 19, 2009 9:00 am    Post subject: Reply with quote

Argh. We upgraded SDL-Net from version 1.2.6 to 1.2.7. It doesn't even update its library version number (which is separate), but it has moved it. It used to be libSDL_net-1.2.so, but now it only has a symlink called libSDL_net-1.2.so.0 to the actual library. This effectively breaks backward compatibility.

I added a compatibility symlink to the recipe in Builder to compensate for this.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Bugs - Fixed All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group