Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

[0.6.6] vlc 1.0.0 > requires pthread_sigmask and glibc &g

 
Post new topic   Reply to topic    Syllable Forum Index -> Bugs
View previous topic :: View next topic  
Author Message
NecroRomancist



Joined: 18 Sep 2007
Posts: 272

PostPosted: Sat Aug 22, 2009 12:50 pm    Post subject: [0.6.6] vlc 1.0.0 > requires pthread_sigmask and glibc &g Reply with quote

VLC 1.0.0 or superior prints the following error on glibc 2.7.



[code:1]
configure: error: Buggy GNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable
work-around for this. Check with your distribution vendor on how to update the
glibc run-time. Alternatively, build with --disable-nls --disable-mozilla and
be sure to not use LibVLC from other applications/wrappers
[/code:1]

After doing that we get to a stage where despite that we get to a bug on iconv (utf8 conversion) - iconv is not usable. Same discussed a while back on libcdio.
FInally we get to a stage where it complains about pthread_sigmask (vlc.c) missing.
Which prevents the later linking stages.
Back to top
View user's profile Send private message
NecroRomancist



Joined: 18 Sep 2007
Posts: 272

PostPosted: Sat Aug 29, 2009 11:06 am    Post subject: Reply with quote

After a bit of fiddling and looking at flags i got vlc 1.0.0 to built. However i'm getting this

http://forum.videolan.org/viewtopic.php?f=13&t=63626

Also it seems we do have pthread_sigmask defined..Still working on it
Back to top
View user's profile Send private message
Vanders
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 849

PostPosted: Sun Aug 30, 2009 6:38 am    Post subject: Reply with quote

[quote="NecroRomancist"]After a bit of fiddling and looking at flags i got vlc 1.0.0 to built. However i'm getting this

http://forum.videolan.org/viewtopic.php?f=13&t=63626

Also it seems we do have pthread_sigmask defined..Still working on it[/quote]

It's defined but not implemented. I have finally [url=http://docs.sun.com/app/docs/doc/816-5168/thr-sigsetmask-3c?a=view]found some documentation[/url] for it, though. It's little more than a wrapper for sigsetmask() with some extra logic for SIG_BLOCK/SIG_UNBLOCK to mangle the sigmask.
Back to top
View user's profile Send private message Send e-mail
NecroRomancist



Joined: 18 Sep 2007
Posts: 272

PostPosted: Sun Aug 30, 2009 2:38 pm    Post subject: Reply with quote

I got vlc 1.0.1 to generate the shared libs. The thing is that i had to disable vlc(the application it self) to do it. If i don't pass disable-vlc it chooses the static libs to build the binary..and doesn't generated the shared libs which are the plugins.It seems that libvlc can be static but the plugins have to be shared..If i only build libvlc and the plugins i get a shared version of libvlc.

http://wiki.videolan.org/LibVLC_SampleCode_SDL

Maybe it would be simpler and better to adapt that code to use Bitmaps no?
Back to top
View user's profile Send private message
Vanders
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 849

PostPosted: Sun Aug 30, 2009 5:56 pm    Post subject: Reply with quote

You'd have to port more than that to get VLC running native on Syllable. Somewhere there is code to create an SDLApplication, for example. It also wouldn't solve the static/shared linker issues you've run into.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group