Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Xynth
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Syllable Forum Index -> Syllable Server
View previous topic :: View next topic  
Author Message
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Mon Mar 26, 2012 10:02 am    Post subject: Reply with quote

Ok, Xynth works now. I had forgotten two seconds delay between "xynth" and "desktop". I even compiled MPlayer with Xynth support.

This is not very fast but it works. Smile

It's Better with SDL or fbdev2 in the console.

Perhaps it would be better a new post about Xynth, right?
Back to top
View user's profile Send private message
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Mon Mar 26, 2012 11:48 am    Post subject: Reply with quote

Thank you.Smile

If you have configured as installation directory "/usr/Xynth" libraries will be installed in "/usr/Xynth/lib" and headers in "/usr/Xynth/include". It is best to move them into "/usr/Xynth/framework/libraries" and "/usr/Xynth/framework/headers". Then do not forget to restart "ldconfig" after "package register Xynth".

Do not forget the delay between the server "xynth" and the application which will be executed after.

For example: xynth& sleep 2; desktop
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Mon Mar 26, 2012 5:47 pm    Post subject: Reply with quote

Also, the installation directory should be /resources/Xynth/

If you let Builder build it, it will use the right directories automatically.

Using ldconfig is not necessary on Syllable.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Tue Mar 27, 2012 3:02 am    Post subject: Reply with quote

If I don't type "ldconfig", "ld.so.cache" is not updated and Xynth doesn't launch. An error message appears about the shared library "libxynth.so".

This is normal because "/usr/index/lib" and "/usr/index/include" is not inside "ld.so.conf". This is here I discovered that shared libraries are not recognized.

I had the same problem with libexpat. If I compile a program with this library, there is no problem. But if later, the program calls the shared library , I have to move or copy the libraries and headers in "framework" without forgetting to retype "package register libexpat" and after "ldconfig" to update "ld.so.cache".
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Tue Mar 27, 2012 5:21 am    Post subject: Reply with quote

That's why you should use the paths that Syllable standardises on. Syllable Server only uses ld.so.cache during the early phase of system startup. After that, it relies on a library search path set in the LD_LIBRARY_PATH environment variable This is like Syllable Desktop, which uses DLL_PATH. LD_LIBRARY_PATH is the standard variable for Linux, but many Linuxes don't use it, at least not by default. ldconfig works on Syllable Server, but the environment variable is easier, because libraries work right away after installation, without calling ldconfig.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Tue Mar 27, 2012 7:27 am    Post subject: Reply with quote

Yes, indeed.

Now, I have another problem for Xynth about FBdev and Vesa.

Yesterday, I tried on Slackware, Xynth with Vesa from the console in text mode. it works well but not on Server 0.4. I think it's because the console is already in graphical mode or because the console uses FBdev.

Apparently, we can use two different drivers with FBdev. With Mplayer, there are two outputs,FBdev et FBdev2. If we use FBdev, Mplayer displays a deformed video. But for FBdev2, it's ok.

May be, by using Server in text mode, I could use Xynth with Vesa or FBdev.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Tue Mar 27, 2012 7:38 am    Post subject: Reply with quote

Hm, I suppose that setting is determined by the Linux kernel boot parameters, in the GrUB menu.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Tue Mar 27, 2012 9:15 am    Post subject: Reply with quote

I added in Grub (1024x768): video=vesa vga=791
But I noticed that Server has loaded the module "nvidiafb".

So, I moved it and I rebooted. The console remained in Vesa mode. I checked with "lsmod" and "nvidiafb" was not loaded. With this setting, I have no problem with color (16/32bits) in SDL and apparently, performances are better.

Now I'm trying to find the configuration file which enables the module, for having something more clean.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Wed Mar 28, 2012 1:43 pm    Post subject: Reply with quote

Odd. That's pretty much what it does on my machine, but I haven't tried removing the frame buffer driver. I haven't found a configuration file for it yet. It may be as deep as the Linux kernel configuration before compiling it.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Thu Mar 29, 2012 11:46 am    Post subject: Reply with quote

On my Server, when I run Xynth with FBdev, I get this error message: "You must be the owner of the current console to use ..."
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Thu Mar 29, 2012 1:48 pm    Post subject: Reply with quote

Are you starting Xynth under the system account? Hardware devices must be accessed using the root/system account.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Fri Mar 30, 2012 2:53 am    Post subject: Reply with quote

I can't login as "system". I added a password for the "system", but when I try to connect, Server accepts my password, I get the message "Last login: Fri Mar ... No mail." but afterwards, there is an automatic logout.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Fri Mar 30, 2012 6:14 am    Post subject: Reply with quote

That's by design. It's explained in the manual. You should simply start programs that need to be root/system with the sudo command, which also has an "s" alias. This is also the case for DirectFB and thus SDL programs.
Back to top
View user's profile Send private message Visit poster's website
Bogomips



Joined: 23 Feb 2011
Posts: 307
Location: France

PostPosted: Fri Mar 30, 2012 11:09 am    Post subject: Reply with quote

I think I found why I have this problem.

In fact, some programs need to have all the privileges (full "root" or full "system") and apparently, it's the case of Xynth.

If I type "sudo" with "-s" option , I can do what I want but I'm still recognized as normal user "administrator" in the console and not as user "system". So, I'm not the owner of the console.
I tried with Slax, and I got the same error by running Xynth.

If I log in as "root" or as simple user, I am the owner of the console and Xynth starts.
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2200
Location: Friesland

PostPosted: Fri Mar 30, 2012 3:59 pm    Post subject: Reply with quote

Why do you use -s? It opens a shell. That's not likely to be necessary for Xynth and things such as DirectFB.

If you do

s whoami

you should get

system

Also, /dev/fb0 is assigned to user system and group video. You should be able to make the frame buffer available to administrator and other users by adding them to the video group in /etc/group
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Syllable Server All times are GMT - 6 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group