Syllable Forum Index Syllable
Syllable Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Wrongly set symbolic link in the development package

 
Post new topic   Reply to topic    Syllable Forum Index -> Bugs
View previous topic :: View next topic  
Author Message
maribu



Joined: 05 Jun 2013
Posts: 17

PostPosted: Sun Jun 09, 2013 4:53 am    Post subject: Wrongly set symbolic link in the development package Reply with quote

Hi!

I just installed the development package for Syllable desktop and stumbled over the following problem: On my system the symbolic link in "/boot/system/development/headers/syllable/atheos" points to "atheos", so in fact to itself. I think it should point to "../atheos".

This might either be me, doing something wrong during the installation of the development package, or a small bug in the development package.

Regards,
maribu
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2207
Location: Friesland

PostPosted: Sun Jun 09, 2013 12:28 pm    Post subject: Reply with quote

It's probably in the development files pack, so probably a bug. It looks created by some program when making a symlink while the target directory is already present. However, it's probably also harmless. What matters is that headers/syllable/ should be a symlink to headers/atheos/ or the other way around.
Back to top
View user's profile Send private message Visit poster's website
maribu



Joined: 05 Jun 2013
Posts: 17

PostPosted: Sun Jun 09, 2013 12:33 pm    Post subject: Reply with quote

Hi, Kaj!

I had a problem compiling a program until I corrected the symlink. So it seems to be not totally harmless.

Regards,
maribu
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2207
Location: Friesland

PostPosted: Sun Jun 09, 2013 2:03 pm    Post subject: Reply with quote

Odd, I never had an immediate problem after installing the development packages. Do you have it with all programs? I'll keep it in mind.
Back to top
View user's profile Send private message Visit poster's website
maribu



Joined: 05 Jun 2013
Posts: 17

PostPosted: Sun Jun 09, 2013 2:20 pm    Post subject: Reply with quote

No, is seems like almost all programs compile fine. I had the problem compiling adb (Android Debuging Bridge). On a Linux machine I can successfully forward the wlan connection of my mobile phone, so the Linux machine can use the internet connection of the android device.

I thought it would be a try to get network to my Eeepc this way. It still does not compile: The libusb-backend of adb seems not to like Syllable.

Regards,
maribu
Back to top
View user's profile Send private message
Kaj
The Knights of Syllable


Joined: 14 Sep 2007
Posts: 2207
Location: Friesland

PostPosted: Sun Jun 09, 2013 2:34 pm    Post subject: Reply with quote

Interesting port. Smile

LibUSB has forked into two successors. Both of them need to be ported anew to Syllable, so it's another bad situation. Syllable still has the older generation, so your bridge probably wants the new LibUSB version that has become most popular.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Syllable Forum Index -> Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group